スカイアイビジョン株式会社

よくあるご質問

質問をクリックすると回答が表示されます。
表示された回答の質問を再度クリックすると回答が閉じます。

質問1SKY·i·vision は、簡単にいうとどのようなソフトですか?

公図オンマップソフト SKY·i·vision は、「公図PDF」から地図画像をトリミングし(切り出し)、それに位置情報を与え、新たな「デジタル画像」に編集して出力するソフトです。

出力された「デジタル画像」は、Google Earth Pro等のWeb地図やGISの画面に、間単に重ね合わすことができますので、土地の場所が、「簡単」、「くっきり」、「スピーディー」に表示されます。

更に、次の4つの機能を有し、不動産の取引、地域づくり、行政などの業務に加え、住所地を検索するツール等として幅広い仕事に活用いただけます。

簡便・確実性と即時性・・・「簡単」、「スピーディー」

主な作業は、OCR技術を活用するなどして自動化されており、多くの作業は「クリック」だけで済むことから、操作が「簡単」で、業務を効率的に進めることができます。

皆さんの会社や事務所では、一つの土地の公図があったとして、その公図の示している場所を探すのに、どのくらいの時間が必要でしょうか。多数の土地があるときにはどうでしょうか。場所は正確ですか?

SKY·i·visionを使えば、場所さがしの確実性が増すばかりでなく、そうした時間を大幅に短縮し、「スピーディー」に表示することを可能にしました。

製品概要にあるPC中央の画面の「」をクリックすると、“簡単”、“くっきり”、“スピーディー”を動画で体験できます。

柔軟対応力・・・「どんな公図も活用可能」

座標や縮尺のある公図ばかりでなく、座標や縮尺のない公図など、さまざまに精度の異なる公図全般の利用が可能です。また、法務局の証明書付きの「紙の公図」も、スキャナーで読み込んでPDF化して活用できます。質問6~質問11では、その具体的な活用方法を紹介しています。

汎用力・・・「様々なGISソフトでの利用が可能」

出力できるのはKMZ、Geotiff、HTMLの3種類のファイルですが、これらのファイルはWeb上の地図や、さまざまなGISソフトにも読込み可能で汎用性に富んでおり、公図をGoogle Earth Proなどばかりでなく、その他多くのGISソフトで活用できますので、大変、便利です。

明示力・・・「くっきり」

出力する際の公図の線の色が最大48色、太さの選択が6段階あり、重ね合わせるデジタル地図の背景にあわせて、見栄え鮮やかに、「くっきり」と表示することができますので、プレゼンテーションなどでのアピール度を高めることができます。

質問2SKY·i·visionの名前には、どういう意味があるのですか?

SKY·i·visionという名称には、「空からの目」でヒト・コト・モノを捉え直してみようとの願いを込めました。

SKY·i·visionで作成されたKMZファイルをGoogle Earth Proで開くと、地球の浮かぶ宇宙空間から、公図がマッピングされた場所にどんどんズームインしてゆきます。その間は、まるで自分が高速で「時空」をも超えて飛んで行くような気分です。

「Sky・i」とは、そのときの「空からの目」のことです。私たちは通常は「地上の目」で「ヒト・コト・モノ」を見て考えています。しかし、空から俯瞰の、「地上の目」とは異なった視点で「ヒト・コト・モノ」を見直せば、いつもは見逃している大切な何かに気づくことができるかもしれません。私は、「空からの目」で土地を見たとき、碧い海に囲まれ、青い空に白い雲の浮かぶ、まるい地球に土地があるんだなあということが実感されます。そして、それまでは自分とは無関係と思っていた遠い国の人や出来事を、身近な問題として感じさせてくれます。

また、「i」は、地域のいろいろなヒトやコトやモノを結ぶ「integrate」の「i」です。科学の「科」とは、穀物を量り分けること、分類することの意味であり、それを突き詰めると縦割りで孤立無援の「たこ壷」状態の学問が生まれてしまいます。SKY·i·visionが、孤立したそれらを結合させ、「ヒト・コト・モノ」を全体として一体的に考えるきっけをつくることに役立てばいいなと思います。

そして、「i」は、「希望」や「将来像」を描く「I」と「愛」です。不動産に係る業務は、不動産の取引ばかりではなく、地域づくりや行政など、係わる分野は多岐にわたります。私たちの生活が土地の上で営まれているからです。そして、そのような不動産の業務に従事する人の願いは、地域や土地の上で生きる住民やお客様の幸福が実現されることです。SKY·i·visionを使うことで、たくさんの「i」の「vision」が描かれるきっかけになれればいいなと思っています。

i」に重ねた思いはもっとあるのですが、最後に、「instant」や「immediately」の「i」についてお話します。「簡単」な操作で「スピーディー」に、公図PDFを位置情報つき画像ファイルに再編集して出力できるということです。

質問3SKY·i·visionを使用すると、公図がどのように生かされるのですか?

SKY·i·visionは、公図PDFを位置情報を与えた「デジタル画像」に再編集して出力し、それをWeb地図やGISの画面に重ね合わせ、土地の場所を「簡単」、「くっきり」、「スピーディー」に知るためのソフトです。

そして、このような機能を有するSKY·i·visionを使うことによって、公図から得られる便益を飛躍的に高めることができるのです。今まで、私たちが公図を使う目的は、土地がどこにあるかを確認するため程度に止まっていなかったでしょうか。しかし、公図にはそれ以上の役割があります。

公図の示す線で囲まれた土地が「容れ物」であるとすると、公図PDFをマッピングすることによって、その「容れ物」の中の「中身」が何なのかを理解することができます。

土地という「容れ物」の「中身」とは、地質や地盤の堅固さであったり、農地であれば土壌の良し悪しであったり、長年、その土地が経てきた地歴であったり、その周囲の地域の人口や年齢構成、所得水準等、さまざまなことです。そのような「土地の属性情報」を知り、活用する目的で作られたのが地理情報システムGISです。

公図に座標が付与され「土地の位置情報」が得られることで、公図をGISの地図にマッピングすることができます。そして、そのことでGISに読み込まれた多岐にわたる「土地の属性情報」を知り、活用することができるのです。政府はGIS用の情報をどんどん公開しています。SKY·i·visionは、このように政府などによって公開された「土地の属性情報」と、「公図の位置情報」を簡単に結合できるツールです。SKY·i·visionを使うことで、公図の持つ効用を最大化することができます。

質問4公図PDFを、地図や航空写真にマッピングすると地形とズレが生じるのはどうしてですか?

公図PDFをマッピングしたとき、Web地図やGISソフトの地図の地形等と、うまく一致しないことがあります。

最近の公図は、技術進歩により高い精度で測量されていますが、それでもズレが生じることがあります。その不一致の根本的な理由としては、(1)平面に投影された座標(平面直角座標系)を、3次元の位置を示す緯度・経度(地理座標系)に変換していることが挙げられます。また、(2)作成時点が古い公図で測量の精度が低い場合や、(3)地震等で土地が動いてしまった場合、(4)航空写真の歪みやズレによる場合、(5)使っているGISソフトやPCの特性に係る場合等も考えられます。正確に境界を確認するには、測量による必要があることを念頭において活用するというのが、公図利用の前提となっているのです。このように、公図の示す土地の境界は、必ずしも現地とピッタリと一致するような厳密な境界を示しているものとは断言できませんが、かなりの高い精度で土地の境界を示しており、境界の確認や査定等の資料として役立てられています。

質問5公図の座標が正しく入力されているのに、誤った場所にマッピングされた原因は何ですか?

それは、世界測地系への移行(平成14年4月)時に座標の補正作業が行われず、旧測地系(日本測地系)のままの公図が提供されているためです。このようなケースが、ごく稀ですが確認されています。

この場合、小さな「ズレ」ではなく、正しい場所より概ね南東方へ400m程度※1の大きな「ズレ」となります。このようなケースに遭遇したときには、公図の所在地を管轄する法務局の表示係に問い合わせ、ご相談ください。

また、旧測地系(日本測地系)のままであることが確認できた場合には、測地系の変更による緯度経度または座標値の変換計算をWeb上で行うサービス等※2を利用し、旧測地系(日本測地系)のままの公図の平面直角座標を、世界測地系に変換計算して座標値を求めてSKY·i·visionに入力すれば、正しい場所にマッピングされます。

  • ※1 各座標系により「ずれ」の詳細な程度は異なります。
  • ※2 「Web版 TKY2JGD」等。

質問6「紙の公図」は有効活用できないのですか?

法務局発行の証明付きの「紙の公図」は、スキャナーやコピー機で「PDF化」して読み込み有効活用することができます。読み込んだ後は、質問8「2018年10月1日以前の公図PDF」と同様の手順で、KMZ、GeoTIFF、HTMLの3種類のデジタルデータを出力することが可能です。「紙の公図」の場合、次のような欠点がありますが、土地の位置を確認したりするには有効ですのでお試しください。

  • 登記情報提供システムからダウンロードした公図PDFと、「紙の公図」のレイアウトが異なるため、「紙の公図」に記載されている座標を正しく入力しても、出力されたファイルはGIS画面上で正しい位置からズレた状態で表示されます。いくらコピー機の角に「紙の公図」の角を併せたりして調整しても、SKY·i·vision (Ver1.0.0)では、地図画像としてトリミングされる(切り出される)部分が、登記情報提供サービスからダウンロード取得した新レイアウトの公図に合わせてありますので、ズレが生じてしまいます。
  • 「紙の公図」をPDF化したものをマッピングすると、必要な線以外のノイズが出てしまいます。

質問7「紙の公図」の欠点は解消できないのですか?

「紙の公図」を有効活用する場合の欠点は、次のように対処すれば、影響を緩和することが可能です。

まず、質問6の(1)については、殆どのGISソフトには、画面上で画像を移動させ、位置を調整する機能※1がありますので、当該機能を使って公図の画像を移動して正しい位置に調整することが可能です。そして、調整後の画像を保存しておけば※2、次から正しい位置にマッピングされます。以上は、KMZの場合です。GeoTIFFの場合は、位置を調整したファイルをKMZ等で保存することができます。HTMLは位置の調整機能自体がありません。

次に、質問6の(2)の欠点については、紙の公図をPDF化する際に「うすめに」コピーし、その上で、線の太さを「1~3」程度にして出力すると、ノイズの影響をできるだけ小さくすることができます。出来栄えには、「紙の公図」の状態や、PDF化する際の画像の濃さと、出力する際の線の太さの三者が影響します。相互関係を上手にコントロールしてみてください。また、更に精緻な方法として、画像編集ソフトでノイズや不必要な線等を除去する等のやり方もあります。

  • ※1 GISソフトの位置を調整する機能・・・Google Earth Proの場合、画面の左上にある「▼場所」に、読み込まれたKMZファイルがあります。「当該KMZファイル名のところをダブル・クリックする」→「ファイル名の下に更に同じファイル名が出てくる」→「それを右クリックするとWindowが出てくる」→「その最下段のプロパティーをクリックする」の手順で進むとGoogle Earth Proに重ね合わされているKMZファイルの画像がみどり色に枠取られ、移動したり、変形したりできるようになります。あとは工夫しながら調整を図ります。
  • ※2 KMZの保存の手順・・・Google Earth Proの画面で左側に示されている、「▼場所」に示されている該当するKMZファイル名を右クリックすると、操作の選択のwindowが開かれますので、「名前を付けて場所を保存」をクリックします。(「ファイル(F)」→「保存」→「名前を付けて場所を保存」でも同じです)
    なお、手間がかかりますが、より精緻な方法もあります。まず、「紙の公図」をPDF化し、それを画像編集ソフトで読込みます。次に、その画像を登記情報提供サービスでダウンロードした新しいレイアウトの公図を下敷きにして、公図部分の位置を調整してA3で保存します。保存された調整後の公図PDFは、新しいレイアウトの公図と同じように位置調整の心配なく使用できます。(詳しい手順は「よくある質問15」参照)

質問8「2018年10月1日以前のレイアウト変更前」の公図PDFを使えますか?

2018年9月30日までに登記情報提供システムからダウンロードした公図PDFは、2018年10月1日以降の公図PDFとレイアウトが異なるため、「縮尺」と「座標値」が正常に読み込めません。しかし、縮尺と座標値を一カ所だけ手入力すれば、「A点→B点計算」機能※1で簡単にもう一つのポイントの座標値が自動算出されます。

手順は、2018年10月1日以前の公図PDFを普通に読み込んだら、まず、公図PDFを参照しながら※2、「縮尺」を手入力します。次に「座標」のうち右上角(A点)の座標値を手入力して、「A点→B点計算」をクリックすると、左下角(B点)の座標値が自動計算されます。あとは通常どおりの手順で進めば、2018年10月1日以降の公図PDFと同様の精度でKMZ、GeoTIFF、HTMLの3種類のファイルを出力することができます。「紙の公図」の場合のような位置のズレやノイズの問題はありません※3

  • ※1 マニュアル「3.1.3.」(P10~P11)参照。
  • ※2 シートの一番下にある「公図PDF」ボタンをクリックすると、読み込んでいる「公図PDF」が出てきますので、参照しながら確実に入力できるようになっています。(マニュアル「6.1. 公図PDFの確認」(P26)参照)
  • ※3 2014年3月24日以降の公図は、図面部分のレイアウトが同じですのでズレの問題がありませんが、2014年3月24日以前の公図は図面部分のレイアウトも異なりますのでズレの問題が生じます。2014年3月24日以前の公図は、「よくある質問6」、「よくある質問7」の「紙の公図」と同じ方法で対処します。

質問9「座標や縮尺のない公図」は有効活用できないのですか?

「座標や縮尺のない公図」も、SKY·i·visionにそのまま読み込み、有効活用することができます。読み込んだ後は、質問8「2018年10月1日以前の公図PDF」と同様の手順で、KMZ、GeoTIFF、HTMLの3種類のデジタルデータを出力することができます。「紙の公図」の場合のようなノイズの問題はありませんが、位置調整の必要があります。「座標や縮尺のない公図」の活用方法は2つあります。

1. A点の「座標」と「縮尺」を推定して入力する方法

「座標や縮尺のない公図」は、旧い時代に製作されたものです。従って、縮尺は「1/600」、「1/1200」など、縮尺の分母が600の倍数になったものが多いと思われますので、調べたい土地の登記上の面積等を手掛かりにして、まずは縮尺を推定して手入力します。

次に、Google Earth Pro等のWeb地図を利用して、公図の示す位置を推定し、公図の右上角(A点)の座標の「緯度・経度」を推定して手入力します(マニュアルP12「3.2.緯度経度で指定する場合」参照)。あとは、普通の手順で行います。位置の調整を行うのは「紙の公図」(質問6、質問7参照)と同じです。

2. 「座標」のみを推定して入力する方法(「縮尺」は入力しない)

「座標や縮尺のない公図」は、旧い時代に製作されたものが多いですので、「座標と縮尺」の両方をいくら正しいく入力しても、正しい位置に表示されないことがあります。そのような場合には、縮尺を入力せずに、公図の右上角(A点)ばかりでなく、公図の左下角(B点)の座標も推定して手入力するという方法が有効な場合もあります。位置の調整を行うのは1と同じです。

質問10複数ページの公図PDFのすべてページのPDFをマッピング出来ますか?

SKY·i·vision (Ver.1.0.0)では、公図PDFの先頭のページについてマッピング可能となっています。よって、すべてのページのPDFをマッピングするには、複数ページの公図PDFを、1ページずつに分割する必要があります。次のようにすれば、効率的に作業できます。

登記情報提供サービスからダウンロードした公図PDFは直接編集ができないようにパスワード保護がかけられていますので、まず、(1)ダウンロードした公図PDFを「A3」の大きさで「出力(または印刷)」します。出力(または印刷)されたPDFはパスワード保護がかけられていない公図PDFとなりますので、次に、(2)パスワード保護がかけられていないA3で出力されたPDFを、CubePDF Page(フリーソフト)等のPDF分割ソフトで1ページ毎に分割します。それぞれのページを1ページずつ出力(印刷)したりしても同じことですが、この方が断然、効率的です。

質問11複数ページの公図PDFをマッピングしたら、それぞれがきちんと接続していないのはどうしてですか?

複数ページの公図PDFをマッピングしたとき、それぞれの画像がきちんと接続せず、すき間があったり、一部が重なったりする場合があります。

この原因は、平面に投影された座標(平面直角座標系)を、3次元の位置を示す緯度・経度(地理座標系)に変換しているからです。縮尺が小さい1/1000以下の場合により目立ちます。また、Google earth Pro上では、傾斜のある土地の場合にも目立つように感じることが多いようです。

複数ページの公図PDFを一括処理する方法を工夫すると、上記の欠点が解消できることが分かっています。

一括処理できる機能は、現在、開発中です。

質問12GeoTIFFファイル出力を試みると、下図のエラーメッセージが表示されてしまうPC端末があります

(C:\Program Files\GDAL\gdalplugins)フォルダ内から「ogr_MSSQLSpatial.dll」を削除した後に、GeoTIFFファイル出力を再度試みてください。

質問13GeoTIFFファイルをGoogle Earth Proで開いた時に、赤色の×マークで表示されてしまいます

これはGoogle earth Proの仕様もしくは設定に依存する問題ですので、設定の見直しをお願いいたします。なお、Geotiffファイルの再読み込みを行うと正しく表示ますので、次の手順に従ってお試しください。

手順

  1. 「インポートしたイメージのサイズが、ハードウェアでサポートされている最大サイズに比べて大きすぎます。・・・」のメッセージがでます
  2. そのウィンドウ下段にある「縮尺」のボタンをクリックします
  3. そうしますと画面上に四角形で囲まれた赤色「×」マークが出て、同時に「新規イメージオーバーレイ」のウィンドウがでます
  4. 上から2行目の「リンク」欄の右側の「参照」ボタンを押して、正しい「リンク先」(GeoTIFF画像のある場所)を選択(指定)します
  5. GeoTIFF画像が表示されます。

質問14地図太郎PULSでGeoTIFFファイルを開くと、背景の色が黒くなりますがどうしたらいいですか?

SKY·i·visionで作成したGeoTIFFファイルは、線以外の地の部分が透過していますので、地図太郎PULSの仕様では、その部分が黒く表示されてしまいます。地図太郎PULSに公図画像を表示させる場合には、以下の方法をお試し下さい。

1. Google Earth ProでKMLファイルを作成する方法

SKY·i·visionで作成したKMZファイルをGoogle Earth Proで読み込み、KMLファイルで保存(名前を付けて保存)し、保存したKMLファイルを地図太郎PULSで表示させます。

2. SKY·i·visionで作成したKMZファイルを解凍する方法

KMZファイルはKMLファイルと画像ファイルを合わせて圧縮したファイルとなっています。よって、KMZファイルを解凍し(フリーソフトが多数あります)、KMLファイルを地図太郎PULSで表示させます。

注意!・・・SKY·i·visionでKMZファイルを作成する際には、必ず、ファイル名は半角英数として下さい。SKY·i·visionで作成したKMZファイルに日本語等があると、KMLファイルのファイル名が文字化けし、画像ファイルが読み込めなくなります。

3. 地図太郎PULSでKMZファイルを解凍する方法(裏技)

最新バージョンの地図太郎PULS(Version4.61-2018年12月時点)で、「他形式を編集ファイルに読み込み」でSKY·i·visionで作成したKMZファイルを指定すると「開くことができません」というエラーメッセージが表示されます。しかし、KMZファイルと同じフォルダの中の<files>という名前のフォルダにKMLファイルと画像ファイルも格納されています。このKMLファイルを、地図太郎PULSで表示(「背景地図を開く」メニューからラスタ地図を選択して表示させてみて下さい。2と違い、KMZのファイル名を半角英数とする必要はありません。

上記1~3で作成したKMLファイルは、全て次の手順で開きます。詳しくは地図太郎PLUSのマニュアルをご覧ください。

手順

  1. 「背景地図を開く」メニュー
  2. 「ラスタ地図 (Google Earth KMLファイル(イメージオーバーレイ))」を選択

質問15「紙の公図」の精緻な位置調整方法(画像編集ソフトのレイヤーを活用する方法)を教えてください

いろいろな方法があると思いますが、以下に一つの具体的な例を示してみました。なお、手順が込み入っているようですが、画像編集ソフトの扱いになれた人なら簡単に思えるはずです。

準備

必要な公図PDF

  1. 登記情報提供サービスから入手した「新しいレイアウト」の公図PDF(以下、公図PDFのA)※1
  2. 紙の公図をPDF化したもの(以下、公図PDFのB)※2
  • ※1 公図PDFのBの台紙となる「新しいレイアウト」の公図(どの土地でもよい)。
  • ※2 スキャナーで設定する解像度は400dpiと、公図PDFのAの解像度と同じとする。他の解像度でも作業は可能ですが、大きさ調整等の手間が増えることになります。なお、画像編集ソフトで読み込めれればOKなので、PDF以外のデータ形式でも利用可能です。

必要なソフトの例

  1. PDF表示ソフト(ここでは、Acrobat Reader DC(以下、Acrobat DC))
  2. レイヤ機能付き画像編集ソフト(ここでは、Adobe Photoshop Elementsバージョン15(以下、Photoshop Elements))

手順

Acrobat DCでの作業(画像Aの作成)

まず、Acrobat DCで、台紙となる公図PDFのAをコピーして、画像Aをつくります。

  1. 登記情報提供サービスから入手した「新しいレイアウト」の公図PDFのAを、Acrobat DCで開く
  2. 開いた公図PDFのA全体を選択する

    「編集」メニュー → 「すべてを選択」

    「画面の一部をクリック」すると → 公図PDFのA全体が選択され、青色に反転する

  3. 公図PDFのA全体をコピーする(コピーされてできた画像を画像Aとします)

    「編集メニュー」 → 「コピー」※3

    • ※3 画像Aは、PCのクリップボードにコピーされた状態で保たれています。保存された状態の画像Aは、次のステージで、画像編集ソフトでレイヤー1をつくるのに使われます。

    Photoshop Elements(画像編集ソフト)での作業

    次に、Photoshop Elementsで、レイヤー1とレイヤー2をつくり、レイヤー2をレイヤー1の位置に重ね合わせするようにして位置を調整し、最後に、調整後の画像をA3版の大きさのPDFで出力します。

    レイヤー1の作成

    まず、画像Aからレイヤー1を作成します。

    1. Photoshop Elementsを起動する(「エキスパートモード」)。
    2. 画像Aのレイヤー1の作成(次の手順で進むと、画像Aのレイヤー1が作成されます)

      「ファイル」メニュー → 「新規」 → 「クリップボードからの画像」を選択

    レイヤー2の作成

    次に、公図PDFのBを基にレイヤー2を作成します。

    1. 紙の公図から作成した公図PDFのB※1を、画像編集ソフトで開きます(選択します)

      「ファイル」メニュー → 「開く」 → 公図PDFのBを選択して開く

    2. 開かれた公図PDFのBをコピー(公図PDFのBをコピーしてできた画像を画像Bとします)

      「選択範囲」メニュー → 「すべてを選択」 → 「編集」メニュー → 「コピー」

    3. レイヤー1で作成した画像Aに画像Bを貼り付ける

      画面の上部にある画像Aのタブをクリックしてから → 「編集」メニュー → 「ペースト」

      以上の作業によって、画像Aの上に画像Bが重なり「レイヤー2」となります。画面の右側に次のようにレイヤーの構造が示されます。

    レイヤー2をレイヤー1の位置に調整して重ね合わせる

    1. 画面右側のレイヤー2の「レイヤ描画モード」を「通常」から「乗算」にする

      レイヤー2の「レイヤ描画モード」を「通常」 → 「乗算」

    2. 左の大きな画面で、登記情報提供サービスの公図PDFから作成した「画像A」の図面部分のレイアウトに、公図PDFのBから作成した画像Bの図面部分(周囲の枠線)を移動させ重ね合わせる。

      (画面の更に左側にある「移動ツール」を選択すると矢印状の「移動ツール」が出現するので、それを画像Bの上に乗せると画像Bが移動可となるので、できるだけピッタリと重ねる。位置調整された後の画像は、画像Bとは異なる画像となりますので、これを画像Cとします。)

      ※重ね合わせする際、必要があれば、レイヤー2の拡大縮小、角度調整等も行う。

    位置調整後の画像CをA3版の大きさのPDFで出力(印刷)して、sky-i-visionで読み込む

    画像Cが画像Aに重ね合わされた状態で、レイヤー1を削除等し、画像CをA3版のPDF出力(印刷)する。

    ファイル(F)→プリント(P)→プリンター選択(CubePDF等)→用紙サイズA3を選択→プリント(P)